vladdrummer

I'm trying to test Spine for Unity and of course, I downloaded latest release , 4.0
Now, all examples of Spine characters to test are 3.8 and I can't get this thing to work!
I got an error that says "Reimport in 4.0 or change runtime to 3.8"
HOW??? HOW would I, the person who tries this product for the first time, change runtime if you don't provide instructions for this?

I tried to delete Spine folders in Unity project, loaded and installed previous version of Spine-Unity - no help. It doesn't work.
Even your official SpineBoy character on an official site Won't import - it says "I'm 3.8, can't run on 4.0 'cause my developers didn't update me"

How can I switch Unity runtime to 3.8 ?
vladdrummer
  • Postovi: 5

Nate

Sorry you're having trouble. I know it can be frustrating when trouble starts in the first few steps! Harald, our Unity guru, is sleeping in his time zone at the moment so I'll try to help, otherwise he can assist when it's morning for him.

There's an Older Versions section on the Unity download page where you can get 3.8:
Spine Unity Download: Older Versions

Also FWIW the source code for the 3.8 runtimes is in the 3.8 Git branch:
https://github.com/EsotericSoftware/spine-runtimes/tree/3.8
Now, all examples of Spine characters to test are 3.8 and I can't get this thing to work!
Where did you get the 3.8 examples? The 4.0 runtime should have 4.0 examples, the 3.8 runtime should have 3.8 examples, etc.

The examples that come with the runtime should match the runtime version, but if needed you can find the 4.0 examples in the examples folder in the 4.0 branch:
https://github.com/EsotericSoftware/spine-runtimes/tree/4.0/examples

Similarly, the 3.8 examples are in the 3.8 branch:
https://github.com/EsotericSoftware/spine-runtimes/tree/3.8/examples

I would suggest downloading the the whole branch to get the files (go to root of branch, click Code, then Download ZIP) rather than downloading project files one-by-one.
Avatar
Nate

Nate
  • Postovi: 11791

vladdrummer

Hi!
Nate je napisao/la:There's an Older Versions section on the Unity download page where you can get 3.8:
Spine Unity Download: Older Versions
Yes, but when I first installed 4.0 - nothing lets me downgrade to 3.8. I downloaded 3.8 after installing 4.0 , opened it in Unity and still get the error.
Nate je napisao/la:Where did you get the 3.8 examples? The 4.0 runtime should have 4.0 examples, the 3.8 runtime should have 3.8 examples, etc.
The page with examples :
Spine: Example Projects
I guess it's an official site and it's all for 3.8. Can't run them in Unity - get the same error.
The examples on the Unity Asset Store are all 3.8 and just unusable.
The Spine Examples/Spine Skeletons folder in Unity doesnt have .asset files or anything draggable to the scene. I can open sample scenes and dragcharacters from scene as prefab, but that's you know.. Not right.
vladdrummer
  • Postovi: 5

Harald

vladdrummer je napisao/la:I got an error that says "Reimport in 4.0 or change runtime to 3.8"
HOW??? HOW would I, the person who tries this product for the first time, change runtime if you don't provide instructions for this?
Sorry to hear you're having problems. Did you check out the Getting Started section on the spine-unity documentation page (it's also linked at the top of the download page)?
spine-unity Runtime Documentation: Getting Started
There is also an extensive section on updating the spine-unity runtime here:
spine-unity Runtime Documentation: Updating the spine unity Runtime
If you already read these sections and any info on this page is unclear, please let us know. We're always happy to improve the documentation.
vladdrummer je napisao/la:Yes, but when I first installed 4.0 - nothing lets me downgrade to 3.8. I downloaded 3.8 after installing 4.0 , opened it in Unity and still get the error.
Are you sure that you also deleted the Spine Examples directory?
http://esotericsoftware.com/spine-unity#Updating-the-spine-unity-Runtime je napisao/la:When upgrading to a different major or minor version (e.g. from 3.7 to 3.8 ), delete the previous spine-unity installation directories Assets/Spine and Assets/Spine Examples from your project.
Basically deleting the two directories and importing the spine-unity unitypackage is all that needs to be done to downgrade the runtime.
vladdrummer je napisao/la:The page with examples :
Spine: Example Projects
I guess it's an official site and it's all for 3.8. Can't run them in Unity - get the same error.
Did you perhaps open the example projects with your Spine Editor version set to 4.0? If you then export these projects with version 4.0, you have opened the example 3.8 project with 4.0, auto-upgraded it to 4.0 and exported it as 4.0.
vladdrummer je napisao/la:The examples on the Unity Asset Store are all 3.8 and just unusable.
We neither provide examples, nor the spine-unity runtime on the Unity Asset Store (due to Unity's license models). So anything you find on the Asset Store is a thirdparty asset, which unfortunately we have no control of.
vladdrummer je napisao/la:The Spine Examples/Spine Skeletons folder in Unity doesnt have .asset files or anything draggable to the scene. I can open sample scenes and dragcharacters from scene as prefab, but that's you know.. Not right.
If you imported some skeleton assets with errors before you need to reimport them. As described in the Updating the spine-unity Runtime section:
http://esotericsoftware.com/spine-unity#Updating-the-spine-unity-Runtime je napisao/la:When upgrading to a different major or minor version, re-import the skeleton assets by selecting right-click - Reimport All in the Project panel. Alternatively to not re-import all assets, you can locate the folder containing your Spine skeleton assets in the Project panel that you want to re-import, right-click on the folder, then select Reimport.
Avatar
Harald

Harri
  • Postovi: 3914

vladdrummer

Harald je napisao/la:Are you sure that you also deleted the Spine Examples directory?
It happens in a completely new project as well. Spine is in multiple places of Unity menu , so it's not just folders in Unity project
Harald je napisao/la:Basically deleting the two directories and importing the spine-unity unitypackage is all that needs to be done to downgrade the runtime.
it absolutely doesn't and gives me "change runtime" even on a new project with 3.8 installed
Harald je napisao/la:We neither provide examples, nor the spine-unity runtime on the Unity Asset Store (due to Unity's license models). So anything you find on the Asset Store is a thirdparty asset, which unfortunately we have no control of.
So why official site gives me 3.8 examples that I cannot use?
Harald je napisao/la:If you imported some skeleton assets with errors before you need to reimport them. As described in the Updating the spine-unity Runtime section:
It's just importing spine-unity package. I think, everything there SUPPOSE to work out of the box.
Maybe because I installed 4.0, and then 3.8 , reimport do nothing and I can't drag .asset to a scene.
Harald je napisao/la:Did you perhaps open the example projects with your Spine Editor version set to 4.0? If you then export these projects with version 4.0, you have opened the example 3.8 project with 4.0, auto-upgraded it to 4.0 and exported it as 4.0.
I don't have Spine Editor, I just wanted to test this solution with Unity and it went horrible from the start.
This doc: spine-unity Runtime Documentation: Getting Started says "get latest release" and this page Spine: Example Projects , which is your site, contain stuff I can't use.
Why not making choose runtime version in Unity? If you don't like deprecation model and old versions doesn't work on a new runtime - why don't you let us choose runtime version with a dropdown?

As far as I understood, there is no solution other than buying Spine Editor which I don't need and convert old models from your site?
vladdrummer
  • Postovi: 5

Harald

vladdrummer je napisao/la:It happens in a completely new project as well. Spine is in multiple places of Unity menu , so it's not just folders in Unity project
The scripts from these two folders add menu entries to Unity menus. If you delete the two directories, your menu entries will be gone as well. If you extract the spine-unity 3.8 unitypackge into a clean project, the included example scenes and skeleton assets in the Spine Examples directory all match this runtime and work fine.
vladdrummer je napisao/la:it absolutely doesn't and gives me "change runtime" even on a new project with 3.8 installed
Which asset provides this error message for you? We doubt that any of the included Spine Examples assets causes this error message.
vladdrummer je napisao/la:So why official site gives me 3.8 examples that I cannot use?
The provided examples on Spine: Example Projects are Spine Editor 3.8+ projects compatible with the Spine Editor set to version 3.8 and newer. They are intended to be examples for the Spine Editor. There are pre-exported .json and .skel files included in each zip package, but they are exported for the current 4.0 version, which might have caused your problems. Also, the spine-unity runtime has the special requirement of all Spine runtimes that the .atlas asset needs to have the extension .atlas.txt, which is an unfortunate Unity requirement (described here). For runtime examples, we provide the examples alongside each runtime, which is setup to work out of the box without modification. I assume that this confusion of Example Project (for the Spine Editor) and runtime example assets has caused your troubles.

If you try to import a 4.0 skeleton asset with the spine-unity 3.8 runtime, it will tell you that you need to use spine-unity 4.0 to import it, or re-export your asset from the Spine Editor set to version 3.8.
vladdrummer je napisao/la:I don't have Spine Editor, I just wanted to test this solution with Unity and it went horrible from the start.
Sorry to hear.
vladdrummer je napisao/la:This doc: spine-unity Runtime Documentation: Getting Started says "get latest release" and this page Spine: Example Projects , which is your site, contain stuff I can't use.
As described above, these projects are example Spine Editor projects, for you to inspect in the Spine Editor. The pre-exported assets in each zip package are for 4.0 runtimes, and for spine-unity they need the .atlas asset renamed to .atlas.txt. Also the included assets in the zip packages contain several versions of assets, ess and pro versions of a skeleton, .json and binary .skel files, PMA and straight alpha atlases. Then you can use them in spine-unity as normal. If you have already imported the skeleton file, but your .atlas.txt file was misnamed to .atlas, you need to delete the _SkeletonData asset before reimporting to automatically assign the atlas asset at the _SkeletonData asset (and avoid having to manually assign it).
vladdrummer je napisao/la:Why not making choose runtime version in Unity? If you don't like deprecation model and old versions doesn't work on a new runtime - why don't you let us choose runtime version with a dropdown?
All scripts and example assets in the spine-unity runtime need to be replaced, a "choose runtime version" on the Unity side would not make sense, it would just download the respective unitypackage.
vladdrummer je napisao/la:As far as I understood, there is no solution other than buying Spine Editor which I don't need and convert old models from your site?
It seems like you misunderstood the situation in two ways, please be sure to check out the first paragraph of the spine-unity documentation page:
Integrating an official Spine Runtime into your applications requires a valid Spine license, though you are welcome to use the Spine Runtimes for evaluation purposes.
So without purchasing a license of the Spine Editor you are not allowed to include the spine-unity runtime in your product. Spine Editor License Agreement

Secondly, as mentioned above, you could use the pre-exported 4.0 skeleton assets downloaded as example zip packages as well without upgrading them, you need to rename .atlas to .atlas.txt to use it with Unity.
Avatar
Harald

Harri
  • Postovi: 3914

vladdrummer

Harald je napisao/la:The scripts from these two folders add menu entries to Unity menus. If you delete the two directories, your menu entries will be gone as well. If you extract the spine-unity 3.8 unitypackge into a clean project, the included example scenes and skeleton assets in the Spine Examples directory all match this runtime and work fine.
No, it doesn't work. I filmed this whole process and it doesn't work.
Here's youtube link:
https://youtu.be/43VpUZrnpRg
As you can see, nothing works.
Harald je napisao/la:So without purchasing a license of the Spine Editor you are not allowed to include the spine-unity runtime in your product. Spine Editor License Agreement
But "though you are welcome to use the Spine Runtimes for evaluation purposes." - it's what I'm using it for. It's not working - should I pay for it?
vladdrummer
  • Postovi: 5

Harald

vladdrummer je napisao/la:No, it doesn't work. I filmed this whole process and it doesn't work.
Here's youtube link:
https://youtu.be/43VpUZrnpRg
As you can see, nothing works.
Thanks for recording the video, it helps a lot in understanding what went wrong.

1) Regarding the downloaded example project it's as I wrote above:
Harald je napisao/la:As described above, these projects are example Spine Editor projects, for you to inspect in the Spine Editor. The pre-exported assets in each zip package are for 4.0 runtimes.
So please use the spine-unity 4.0 runtime when importing these pre-exported example assets from the zip packages. When you try to use the 3.8 runtime, it will not import but instead issue the warning.

2) Regarding drag and drop not working: You dragged several assets to the Scene and Project panels, mostly the _Atlas asset then some Textures, but never the _SkeletonData asset (as described here on the documentation page). When using Unity's Project Panel in zoomed-in view, you see the _SkeletonData asset as a preview of the skeleton already. If you have a hard time seeing which asset is which, either drag the Project Panel's zoom slider to the left to see the icons (which are easier to distinguish), or have a look at the filename in the bottom bar of the Project Panel.
vladdrummer je napisao/la:But "though you are welcome to use the Spine Runtimes for evaluation purposes." - it's what I'm using it for. It's not working - should I pay for it?
Of course usage for evaluation purposes is fine. We would just recommend to use it in the way it is described to be used, otherwise you will encounter a lot of frustration when doing the opposite of what is described in the documentation pages.
Avatar
Harald

Harri
  • Postovi: 3914

Nate

As Harald mentioned, the example projects downloaded from the examples pages will give you the latest version (4.0):
Spineboy example

You don't need to download those projects though, as the runtime comes with the example projects that match the runtime version. Alternatively you can get the examples for a particular version from Git, as I mentioned above.

Another option is to copy the link for the Download button on the example page. For example, it gives a link like this:
http://esotericsoftware.com/files/examples/latest/spineboy/spineboy.zip
If you change latest to 3.8 then you'll get the 3.8 example ZIP:
http://esotericsoftware.com/files/examples/3.8/spineboy/spineboy.zip
We've been meaning to improve this, to allow choosing a version to download on the examples page. However, most users use the examples that come with the runtime and/or the latest runtimes, so it hasn't been a high priority. Sorry it tripped you up!
Avatar
Nate

Nate
  • Postovi: 11791

vladdrummer

Nate je napisao/la:You don't need to download those projects though
But it's the ony ones that working.
The "Examples" .asset files from skeletons folder are not draggable to scene, when installing 4.0
vladdrummer
  • Postovi: 5

Harald

vladdrummer je napisao/la:But it's the ony ones that working.
The "Examples" .asset files from skeletons folder are not draggable to scene, when installing 4.0
Please do as described above, then the skeleton assets are draggable to the scene:
Harald je napisao/la:2) Regarding drag and drop not working: You dragged several assets to the Scene and Project panels, mostly the _Atlas asset then some Textures, but never the _SkeletonData asset (as described here on the documentation page). When using Unity's Project Panel in zoomed-in view, you see the _SkeletonData asset as a preview of the skeleton already. If you have a hard time seeing which asset is which, either drag the Project Panel's zoom slider to the left to see the icons (which are easier to distinguish), or have a look at the filename in the bottom bar of the Project Panel.
Avatar
Harald

Harri
  • Postovi: 3914


Natrag na Unity