uriaamuzig

Bones that have ik to them are hollow so I can't turn them, I saw in a tutorial that I could turn off the visibility on the ik but when I look in my tree I can't turn it off, please help!
Btw, I don't want to turn off ik completly, just turn it off for a moment so I can make smaller changes to the animation

Sorry, t's kind of a basic question but I just can't figure this out.
uriaamuzig
  • Postovi: 3

Misaki

Hi, I guess what you are looking for is Mix: Constraints: Mix
Constraints have "mix" sliders that allow the constraint to be partially applied. When the slider for a constrained property is at 0, the constraint is not applied for that property.
Please note the visibility of IK constraints does not toggle IK enable/disable.
Avatar
Misaki

Misaki
  • Postovi: 763

Nate

Long ago Spine had a visibility dot for IK, but we've removed it because it was a little confusing to have two ways to turn it off (like it is when hiding a slot!). Using mix is the right way to turn off any constraint.
Avatar
Nate

Nate
  • Postovi: 11939

uriaamuzig

I am aware of the mix function of the ik. it just that what I wanted to do was to do Ik for the general pose and then fk for a more percise adjasment, but when I turn the mix back to 0 the pose I did with Ik is reset, but I can just manage normally with only doing ik or fk on frames
uriaamuzig
  • Postovi: 3

Nate

When the mix is 1, the constraint fully affects the bone and you can't change the FK pose. Note that you can set the mix between 0 and 1, then you can adjust the FK pose and the pose you see is the final pose, somewhere between the FK and IK poses depending on the mix.
Avatar
Nate

Nate
  • Postovi: 11939

uriaamuzig

Oh thanks! I'll try that
uriaamuzig
  • Postovi: 3


Natrag na Editor