vertebra

Hello,

I just installed Spine on Mac OS Big Sur (11.0) with an Apple M1 ARM chip.

Spine crashes immediately on start before displaying anything.

I see no Spine folder or logs in the ~/Application Support/. I do see an error in the console before the process crashes:
Sandbox: logd_helper(511) deny(1) file-read-data /Applications/Spine.app/Contents/MacOS/launcher/2/lib/server/libjvm.dylib
Let me know if this should be supported yet, and happy to help test a fix if needed.
vertebra
  • Postovi: 2

Nate

Another user has reported the same problem you are having and from what we could discover working with them is that we can likely get Spine to work again with a bit of effort. FWIW, Spine was working when we last tested Big Sur on a dev kit. We've ordered new hardware so we can work on an M1 system firsthand. Unfortunately it may be another 2 weeks before it arrives.
Avatar
Nate

Nate
  • Postovi: 11930

vertebra

Thanks for working on it!
vertebra
  • Postovi: 2

ionrain

Hi Nate,

Is there a progress on this bug? Downloaded the latest package onto m1 air and it fails to start.
I've attached error log below.
Nemaš dopuštenje za pregledavanje privit(a)ka dodan(og)ih postu.
ionrain

Kickstarter 2 backer
  • Postovi: 14

Nate

Not yet, sorry. The M1 hardware shipment was delayed, it should have arrived Dec 9 but we received it last week instead. We haven't made progress on it yet due to the holidays, but we'll work on it soon.
Avatar
Nate

Nate
  • Postovi: 11930

ionrain

I see, thank you!
ionrain

Kickstarter 2 backer
  • Postovi: 14

WickeyWare

Updates @nate?
WickeyWare
  • Postovi: 32

Tolstik

Hello, @Nate!
Hope, you are working on M1 system. Because it's very important for many people to work as soon as possible. Thank you very much for answer) we are waiting for the Spine)
Tolstik
  • Postovi: 1

edengiver

Hello I too am having this problem (just bough a new 13 inch M1 MacBook Pro) as a daily user of spine I would greatly appreciate a fix since switching computers now would be very difficult. Love your product!!
edengiver
  • Postovi: 1

jdowdy6

Same issue. I tried uninstalling and reinstalling as well.

---

Hi all, I reinstalled and Spine is working on my Mac mini M1! I just upgraded today to macOS Big Sur 11.2.2 so not sure if that had anything to do with it (I hadn't tried in a few weeks). So excited to use this amazing program again!
Nemaš dopuštenje za pregledavanje privit(a)ka dodan(og)ih postu.
jdowdy6
  • Postovi: 4

Nate

Sorry for not posting an update in this thread, but we did a launcher update some time ago so Spine runs on M1 hardware.
Avatar
Nate

Nate
  • Postovi: 11930

jdowdy6

No worries, thanks for your hard work!
jdowdy6
  • Postovi: 4


Natrag na Bugs