ChrisTurner1971

Greetings!

So I need to convert some JSON files from 3.8 to 3.5.
I noticed I can use the latest version (4.1) to save out a JSON for 3.6, but that's as far back as that goes.
The skeleton viewer can convert to 3.6 and 2.1. I tried exporting as 2.1 then importing to 3.5, but that gave me an invalid skeleton error.

Anyone have any suggestions?
ChrisTurner1971
  • Postovi: 2

Nate

You want to avoid going back to an older version whenever possible because data is likely to be lost. You may need to fix up your skeleton and animations afterward. Is there any way to avoid needing to go back? If not, maybe you can avoid needing to go back so far? 3.5 is very old.

JsonRollback in the Skeleton Viewer supports going from version 3.3.xx to 2.1.27. I'm guessing that's why your 3.6 -> 2.1.27 conversion didn't work out.

I'm not sure what the difference was between 3.5 and 3.6. Actually I used GitHub to compare the 3.5 and 3.6 branches and there doesn't appear to be any changes to SkeletonJson (which loads the JSON). Have you converting to 3.6 JSON and loading that with 3.5?
Avatar
Nate

Nate
  • Postovi: 11939

ChrisTurner1971

Thanks for the response, Nate.

I just tried opening the 3.8 file in 4.1, then exporting the JSON as 3.6, and importing that to 3.5 and IT WORKED!
You are a golden god! Thank you!
ChrisTurner1971
  • Postovi: 2

Nate

Wooo! Excellent! :D
Avatar
Nate

Nate
  • Postovi: 11939


Natrag na Editor