warmanw

Hi guys,

When Spine window loses focus for long time or PC goes to sleep. spine wont play the animation anymore, playhead will just not move when I hit play. Restarting Spine instance fixes it.

Anyway I can help you with digging more into this?
Avatar
warmanw

Kickstarter Backer
  • Postovi: 347

Nate

Normally the timeline position during playback is based on "wall" time, which what your computer reports as the actual time passed.

When an animation has audio events, the timeline position for playback is based on the time reported by your audio hardware. This may not always match the wall time, so using the audio hardware time makes it more likely that audio is synchronized with playback.

I'm guessing your audio drivers have shat the bed. You could check that you are using the latest drivers. Spine uses OpenAL. If you have multiple audio devices, try changing the device in the Audio view and then changing it back.

For animations where the synchronization is not important, we could have a way to always use wall time. That would let you play your animations, but I doubt you'll hear your audio events when the audio hardware problem occurs.

We'll try reproducing the problem next week. Does it happen if you run Spine, open spineboy-pro.spine, play the run animation to hear the footsteps, pause playback, put the PC in hibernation, then resume?
Avatar
Nate

Nate
  • Postovi: 12131

warmanw

Ah yes I remember Spine showing a toast OpenAL is not responding or what, but dont remember when.

Spineboy has no audio file for footsteps. should I use my own?
Avatar
warmanw

Kickstarter Backer
  • Postovi: 347

Erika

There are some Audio files ready to be used here in case!
https://github.com/EsotericSoftware/spine-superspineboy/tree/master/assets/sounds
Avatar
Erika

Erikari
  • Postovi: 3113

warmanw

Thanks Erika, Yes Nate, the same happens with Spine boy project when I introduced audio events.
Avatar
warmanw

Kickstarter Backer
  • Postovi: 347


Natrag na Bugs