wavebbs

I have optimized a scene with only 2 spine objects for PS4.
It's runing very fast on Unity Editor.

pc.png


But when I run it on PS4 with develop build, Spine costs more than 50ms.
profiler.png


I can change to release build, it's works OK.
But I need to debug on PS4.

Is there anyway that we could fixed it?

I have uploaded profiler file on google driver :
https://drive.google.com/file/d/172cw6C-CCdP06ggjxJ0LSG1y4w5XUP2T/view?usp=sharing

Please check it out, I really appreciate your help.

Thank you so much!
Nemaš dopuštenje za pregledavanje privit(a)ka dodan(og)ih postu.
wavebbs
  • Postovi: 11

bklooster

Congrats on using Spine on a single core jaguar CPU. This is the consequence of using 8 year old tech with the fact that Spine is not multi-threaded. Typically, you're slamming the main Unity script/gameplay thread with Spine skinning instructions.

Things you can try to improve your performance:
  • Enable fast math in spine's MathUtils.cs (USE_FAST_SIN_COS_ATAN2_APPROXIMATIONS) saved us about 10-15% speed.
bklooster
  • Postovi: 10


Natrag na Unity