MisterSouji

Im new here so I hope this is the right forum. I have two skins, one for male and one for female. I have two image attatchments on one slot on a bone. However, Spine will only let me have one attatchment visible on a slot, even switching skins. When I switch skins to the non visible one the attatchments just disappear. The only way I can get around this is making 2 different slots with one attachment each and making them all visible. Im using spine 4 I beleive.
MisterSouji
  • Postovi: 5

Nate

MisterSouji je napisao/la:Spine will only let me have one attatchment visible on a slot
That is expected and how slots work.
Slots - Spine User Guide
MisterSouji je napisao/la:When I switch skins to the non visible one the attatchments just disappear.
I'm not clear on what you are seeing when you switch skins. Attachments under a skin placeholder are only for the currently active skin. If you want the same attachment in a different skin, you'll need to duplicate the attachment, make the other skin active, and put the attachment in the placeholder for the other skin.

See Skin workflows, you may want to duplicate a skin then customize it to reduce the effort needed.

It can help to use Show all skin attachments so you can see multiple skins at once. Then you can move an attachment to a different skin in fewer steps (you don't need to set the other skin as active).
Avatar
Nate

Nate
  • Postovi: 11846

MisterSouji

I guess I need to take some screenshots, but essentially the attatchment isnt showing up on the corresponding skin unless I have the visible eye symbol on, which turns the attatchment off for the other skin. So whenever I switch skins, I then have to manually turn on the visibly for the attatchment to show up.
MisterSouji
  • Postovi: 5

Nate

Alright, though I'm afraid I can't determine the problem from that. It works like this: When using skins, you place your attachments under skin placeholders. If a skin placeholder is visible, the attachment under it will be shown. If you make a different skin visible, any attachment under the skin placeholder for that skin is shown instead. You can't set the visibility of an attachment when it's under a skin placeholder, you can only set the visibility of the skin placeholder.
Avatar
Nate

Nate
  • Postovi: 11846

MisterSouji

Uploaded some images. Just using the Right foot for now. Essentially, the correspofoot isn't becoming visible when I switch skins, and I have to manually make them visible.
Nemaš dopuštenje za pregledavanje privit(a)ka dodan(og)ih postu.
MisterSouji
  • Postovi: 5

Nate

You have a skin placeholder for Foot_R1 and Foot_R1F. What is Foot_R1F? Is that a foot for the female skin? If so, that is not how you want to use skins. Instead you should have a single slot representing the right foot, a skin placeholder which is the placeholder for an attachment that is the right foot that comes from the skin. Like this:
Foot_R1 slot
Foot_R1 skin placeholder
maleskin skin
Foot_R1 attachment for the male skin
femaleskin skin
Foot_R1F attachment for the female skin
You set the Foot_R1 skin placeholder to visible when you want the foot visible, regardless of what skin is active. When the male skin is active the placeholder will have the Foot_R1 attachment. When the female skin is active the placeholder will have the Foot_R1F attachment.

You may want to uncheck Show all skin attachments and look at it, as the skins showing up under the skin placeholders may be adding to the confusion.
Avatar
Nate

Nate
  • Postovi: 11846

MisterSouji

The slot for Foot_R1F is empty for this example, but currently the only way I can get it to let me switch between the two different attatchments is using two different slots with an attatchment each. However thats not set up for the right foot right now, its just an empty slot in this example. I know I need both attachments visible, but it will not let me set both visible. I dont know what Im doing wrong, I've watched several tutorials.
MisterSouji
  • Postovi: 5

Nate

I never mentioned the empty slot Foot_R1F, I mentioned the skin placeholder Foot_R1F. You should not have a skin placeholder per skin. You want to have one skin placeholder and under it you will have an attachment (or none) for each skin.
Avatar
Nate

Nate
  • Postovi: 11846

MisterSouji

This. Thats what was wrong. I though you had to use a placeholder per skin. Thanks for solving the issue. 😁
MisterSouji
  • Postovi: 5

Nate

Great! Glad you got it worked out. :)
Avatar
Nate

Nate
  • Postovi: 11846


Natrag na Editor