terrymisu

Hi,

I just started using the software and I found a minor bug.

When attempting to edit the "Playback" text boxes in Animate mode, when you first click to select a text box, the value is selected, and everything works as expected - you can delete, or type in a new number.

However, if you place the i-beam at the end of the line, and try to use the "delete" key (backspace) you won't be able to delete a character.

If you place the i-beam at the front of the line, both the "delete" key (backspace) and the "del" key do a forward-delete.

It looks like the "delete" key on OS X is behaving like the "del" key.

This also happens when renaming an item. It looks like all text boxes are affected.

I don't know if this is happening on other platforms with the backspace key.

I'm using version 1.0.16 on OS X Mountain Lion 10.8.2.
Avatar
terrymisu

Kickstarter Backer
  • Postovi: 136

terrymisu

I'm using Java7u15.
Avatar
terrymisu

Kickstarter Backer
  • Postovi: 136

terrymisu

This is happening with Java 1.6 also. :/
Avatar
terrymisu

Kickstarter Backer
  • Postovi: 136

terrymisu

This does *NOT* occur with Spine 1.0.16 in Ubuntu with Java 1.6.0_39 (ironically in a VMWare Virtual Machine, same computer). The backspace key works as expected.

Seems like something OS X specific with Spine, unless there's some fundamental weirdness with key handling in the JVM, but I doubt that?
Avatar
terrymisu

Kickstarter Backer
  • Postovi: 136

Nate

I will look at this tomorrow, thanks!
Avatar
Nate

Nate
  • Postovi: 11939

terrymisu

Cool. :) Thanks!
Avatar
terrymisu

Kickstarter Backer
  • Postovi: 136

Chounard

I'm getting the same reaction (backspace acting like the delete key) in the item rename windows. (For example, if I double click to rename a bone or slot.) I'm running on Mac OS X 10.8.2, if that helps.
Avatar
Chounard

Kickstarter Backer
  • Postovi: 50


Natrag na Editor