IndieDoroid

Hi Harald,

I got a question.

I notice each time I stop playing in the editor (2021.2.0f1), this pop up lingers for 2-3 seconds afterwards. Unity won't release control until this is cleared.

dsf.jpg


What is this and is there something I'm doing in my script that's causing this? :wounded:

Thanks
Nemaš dopuštenje za pregledavanje privit(a)ka dodan(og)ih postu.
Avatar
IndieDoroid
  • Postovi: 246

Harald

IndieDoroid je napisao/la:What is this and is there something I'm doing in my script that's causing this? :wounded:
You can check by creating a copy of your project and then removing your scripts from it. Then you see if it still occurs.
Avatar
Harald

Harri
  • Postovi: 3924

IndieDoroid

Harald je napisao/la:
IndieDoroid je napisao/la:What is this and is there something I'm doing in my script that's causing this? :wounded:
You can check by creating a copy of your project and then removing your scripts from it. Then you see if it still occurs.
Oof ok ... but that's a lot of scripts I'm going to have to parse through :'(

You guys aren't seeing this in your own Unity projects, eh? :wounded:

Also what exactly is happening during that method call anyways?

Thanks for the help!
Avatar
IndieDoroid
  • Postovi: 246

Harald

IndieDoroid je napisao/la:Also what exactly is happening during that method call anyways?
You can have a look at the source code, it's provided with the spine-unity runtime. ;) Most likely it's due to the IssueWarningsForUnrecommendedTextureSettings call that takes time here. You can disable that via Edit - Preferences - Spine - Texture Settings Warning.

Alternatively you can change your Configurable Enter Play Mode settings in your project settings (IIRC it's Domain reload):
https://docs.unity3d.com/Manual/ConfigurableEnterPlayMode.html
This seems to lead to calling Initialize all the time.
Avatar
Harald

Harri
  • Postovi: 3924

IndieDoroid

Harald je napisao/la:
IndieDoroid je napisao/la:Also what exactly is happening during that method call anyways?
You can have a look at the source code, it's provided with the spine-unity runtime. ;) Most likely it's due to the IssueWarningsForUnrecommendedTextureSettings call that takes time here. You can disable that via Edit - Preferences - Spine - Texture Settings Warning.

Alternativelty youn can change your Configurable Enter Play Mode settings in your project settings (IIRC it's Domain reload):
https://docs.unity3d.com/Manual/ConfigurableEnterPlayMode.html
This seems to lead to calling Initialize all the time.
Thanks for the help Harald!

I unticked these, but no luck. Still has that 2-3 second pop up after exiting play mode. Thanks for the suggestions anyways. Maybe has to do with Spine auto updating the 100+ Spine assets in the project after exiting player mode. (just a guess)

01.jpg

02.jpg
Nemaš dopuštenje za pregledavanje privit(a)ka dodan(og)ih postu.
Avatar
IndieDoroid
  • Postovi: 246

Harald

Thanks for the additional info, thats is indeed stange.

Since we did not yet encounter this issue and have a hard time preproducing it, you could have a try commenting out sections in the Initialize() method here in SpineEditorUtilities.cs. Then please let us know what part causes the delay for you.
Avatar
Harald

Harri
  • Postovi: 3924

IndieDoroid

Harald je napisao/la:Thanks for the additional info, thats is indeed stange.

Since we did not yet encounter this issue and have a hard time preproducing it, you could have a try commenting out sections in the Initialize() method here in SpineEditorUtilities.cs. Then please let us know what part causes the delay for you.
OK thanks for the tip !

I've moved on to figuring out sprite shapes and probuilder though. I'll let you know when I get back to this one! For the time being I just live with the delaycalls. Spine is just one of the calls, Unity itself has a bunch of executions that fire off after exiting play mode as well. :sleepy:
Avatar
IndieDoroid
  • Postovi: 246


Natrag na Unity