TheRyuka

Hello lovely people.

Again I have a problem and I don't find a solution that works for us.
This is the problem:
We have a talking mode in which the characters switch from talking to idle to talking to idle and so on.
But somehow the idle animation is not displayed correctly. It still has parts of the previous talk animation. Arms beeing on the wrong layer (like they are from the previous talking animation) or parts beeing visible (from the talking) which should be not visible in the idle.
we tried three things to fix it:
1. Make all transition have a transition duration of 0 /no blending
2. Do keys for all parts of the animation on the first frame to really trigger everything.
3. Use code which was recommended for a similar problem:
private SkeletonAnimation skeletonAnimation;
void Start(){
skeletonAnimation = GetComponent<SkeletonAnimation> ();

skeletonAnimation.state.Start += delegate {
skeletonAnimation.skeleton.SetToSetupPose ();
};
Sadly nothing of this worked. Any ideas or suggenstions to fix this problem?
TheRyuka
  • Postovi: 2

Harald

Do you perhaps have Animation cleanup enabled in the Export Settings in Spine? Enabling this option removes keys identical to the setup pose, which would remove the effort of your work you mentioned in (2) above.
Avatar
Harald

Harri
  • Postovi: 3992


Natrag na Unity